bug avec version 2.79 et extension babel

Pour toute demande d'aide sur des exemples non finalisés, c'est ici.
Les exemples aboutis et intéressants seront ajoutés aux sous-forums qui suivent.

Règles du forum
Pour toute demande d'aide pour la conception (ou la confirmation d'un code) d'une figure Asymptote, c'est ici.

J'invite ceux qui ont régulièrement des questions à poser à aller dans leur panneau de l'utilisateur pour indiquer dans la signature de leurs messages :

  1. Nom du système d'exploitation (W7 ou Ubuntu 12.04 ou ...)
  2. Version d'Asymptote et éditeur utilisé pour les figures Asymptote
  3. Distribution LaTeX et éditeur utilisé pour les tex.


On va gagner du temps dans les réponses !
mumblee
Messages : 47
Enregistré le : jeu. 11 mars 2010, 10:29
Localisation : Lille

bug avec version 2.79 et extension babel

Message non lu par mumblee » dim. 28 août 2022, 13:51

Bonjour,

Après m'être débattu pendant un long moment avec du texte qui ne voulait pas se colorer, j'ai cerné le problème avec l'exemple minimal suivant :

Code : Tout sélectionner

import babel;
babel("french");

pair pA=(1,1);

dot("$A$", pA, red);


J'obtiens un point rouge mais une lettre A en noir :
TexteEnCouleur.pdf
(9.31 Kio) Téléchargé 11 fois
Quelqu'un peut-il confirmer le problème ? Merci.

PS : je mets de ce pas ma signature à jour... ;)
Fabrice Eudes
Debian Bullseye 11.4, Asymptote 2.79, texlive 2022, Emacs 27.1

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1499
Enregistré le : dim. 7 mars 2010, 14:50

Re: bug avec version 2.79 et extension babel

Message non lu par GM » dim. 28 août 2022, 15:57

Bonjour,

le problème se produit par exécution directe du code asy ou ce code Asymptote est-il au sein d'un fichier tex ?
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 24/02/21) :
PC n°1 :Windows 10 - Asymptote(2.82)+MikTeX2.9 - Editeurs : Notepad++, TeXworks, Visual Studio Code.
PC n°2 : Ubuntu 20.04LTS - Asymptote(2.67-?? git) + TexLive2020
Mon serveur : Debian Stretch- Asymptote(2.68-16 git) + TexLive2018
Merci de préciser la votre !

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1499
Enregistré le : dim. 7 mars 2010, 14:50

Re: bug avec version 2.79 et extension babel

Message non lu par GM » dim. 28 août 2022, 16:33

Je confirme le problème, en compilation directe, avec les dernières versions Asymptote 2.82 + gs 9.56.1
lorsque l'on a la ligne : babel("french")
et on n'a pas le problème si on remplace "french" par "english" ou "german".

Mais je n'ai pas le souvenir d'avoir ajouté babel dans mes figures personnelles
donc je ne saurais dire si ce problème a toujours existé ou pas.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 24/02/21) :
PC n°1 :Windows 10 - Asymptote(2.82)+MikTeX2.9 - Editeurs : Notepad++, TeXworks, Visual Studio Code.
PC n°2 : Ubuntu 20.04LTS - Asymptote(2.67-?? git) + TexLive2020
Mon serveur : Debian Stretch- Asymptote(2.68-16 git) + TexLive2018
Merci de préciser la votre !

mumblee
Messages : 47
Enregistré le : jeu. 11 mars 2010, 10:29
Localisation : Lille

Re: bug avec version 2.79 et extension babel

Message non lu par mumblee » dim. 28 août 2022, 16:46

Bonjour,

Merci Gaëtan pour cette réponse rapide. Je n'ai même pas eu le temps de préciser en exécution directe :-)

C'est donc un bug qu'il faut remonter ? En tous cas, je n'avais pas pensé à utiliser une autre langue. Cela me permettre de contourner temporairement le problème, donc encore merci !
Fabrice Eudes
Debian Bullseye 11.4, Asymptote 2.79, texlive 2022, Emacs 27.1

Répondre