message d'erreur cygdrive [window7]

Besoin d'aide pour installer Asymptote ?
malaka
Messages : 3
Enregistré le : ven. 14 juil. 2017, 11:37

message d'erreur cygdrive [window7]

Message non lu par malaka » sam. 2 déc. 2017, 09:36

Bonjour après plusieurs échecs j'essaie à nouveau de me remettre à Asymptote.
J'ai régulièrement le message d'erreur suivant et pas de résultat.

Process started
/cygdrive/E//Utilisateurs/***/Mes documents/Asymptote/hello_world.asy: 1.20: unexpected end of input error: could not load module '/cygdrive/E//Utilisateurs/*****/Mes documents/Asymptote/hello_world.asy'
Process exited with error(s)

Pour moi l'erreur vient du double slash souligné en rouge, il ne devrait y en avoir qu'un mais je ne sais pas comment modifié cela. C'est une commande qui "s'écrit" mal mais que faire ?
Window 7 - TeXmaker 5.0.2 -Asymptote 2.41

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1337
Enregistré le : dim. 7 mars 2010, 14:50

Re: message d'erreur cygdrive [window7]

Message non lu par GM » sam. 2 déc. 2017, 13:26

malaka a écrit :
sam. 2 déc. 2017, 09:36
Bonjour après plusieurs échecs j'essaie à nouveau de me remettre à Asymptote.
J'ai régulièrement le message d'erreur suivant et pas de résultat.

Process started
/cygdrive/E//Utilisateurs/***/Mes documents/Asymptote/hello_world.asy: 1.20: unexpected end of input error: could not load module '/cygdrive/E//Utilisateurs/*****/Mes documents/Asymptote/hello_world.asy'
Process exited with error(s)

Pour moi l'erreur vient du double slash souligné en rouge, il ne devrait y en avoir qu'un mais je ne sais pas comment modifié cela. C'est une commande qui "s'écrit" mal mais que faire ?
Bonjour,

j'ai plusieurs questions :
  • Pourquoi cygdrive ? C'est en lien avec cygwin... pour avoir une distribution linux sous Windows... si je ne me trompe pas.
    Mais il y a une version Windows d'Asymptote donc je ne comprends pas.
  • Quel est le code testé ? que contient hello_world.asy ?
  • Quelle a été la commande de compilation ? lancée depuis ?
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 10/10/17) :
PC n°1 :Windows 10 - Asymptote(2.41)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 16.04LTS - Asymptote(2.42 git) + TexLive2017 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

malaka
Messages : 3
Enregistré le : ven. 14 juil. 2017, 11:37

Re: message d'erreur cygdrive [window7]

Message non lu par malaka » sam. 2 déc. 2017, 23:21

Bonsoir, effectivement il manque quelques précisions
Pourquoi cygdrive ? C'est en lien avec cygwin... pour avoir une distribution linux sous Windows... si je ne me trompe pas.
Je ne sais pas. En faisant des recherches je tombe plutôt sur cygwin. cygdrive m'a l'air d'être une commande de changement de répertoire. Pour Linux ? Aucune idée. Je suis sur W7. D'ailleurs j'ai précisé ma config plus bas.
Ceci dit c'est vrai que j'ai l'impression que le problème est plus lié à un truc dans window qu'à Asymptote.
Quel est le code testé ? que contient hello_world.asy ?
juste ça

Code : Tout sélectionner

label("Hello world")
Mais il y a une version Windows d'Asymptote donc je ne comprends pas.
A priori Asymptote 2.41 pour window
Quelle a été la commande de compilation ? lancée depuis ?
Asymptote à travers TexMaker. La commande est la suivante .

Code : Tout sélectionner

"C:/Program Files (x86)/Asymptote/asy.exe" %.asy
.

En fait j'ai déjà réussi à utiliser Asymptote mais de manière trop aléatoire. Sur certains fichiers j'ai l'erreur précédente. Parfois sur deux fichiers différents, dans le même répertoire, l'un fonctionne, l'autre pas. Je ne comprend pas d'où cela vient.
Window 7 - TeXmaker 5.0.2 -Asymptote 2.41

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1337
Enregistré le : dim. 7 mars 2010, 14:50

Re: message d'erreur cygdrive [window7]

Message non lu par GM » dim. 3 déc. 2017, 10:26

Edition du 03/12 à 11h42 : je réagis d'abord ci-dessous à la discussion sur cygdrive... mais la réponse au problème posé est donnée dans ce qui suit : c'est un point virgule qui manque dans le code testé !

Je confirme qu'il ne faut s'étonner de voir cygdrive puisque voilà le résultat d'une compilation réussie via notepad++ (et son plugin NppExec pour lancer asymptote avec F6 en ayant demandé au plugin (option "Follow CURRENT_DIRECTORY") de se rendre dans le dossier du fichier avant de lancer la commande) sur l'exemple. (Quand on a une installation qui fonctionne... on oublie :? certaines choses internes au fonctionnement d'Asymptote.)
2017-12-03_100507.jpg
2017-12-03_100507.jpg (148.17 Kio) Vu 46 fois
2017-12-03_100507_npp.jpg
2017-12-03_100507_npp.jpg (54.5 Kio) Vu 46 fois


Attention : ne pas oublier le point-virgule dans l'exemple !

Figure asymptote 97bb0c1cbe5ca87733a599fea1f8d046
*** Pour masquer/découvrir le code Asymptote qui a permis de créer la figure, il faut cliquer dessus. ;-) ***

CODE ASYMPTOTE de la figure ci-dessus : Tout sélectionner
  1. label("Hello world");


Une autre piste à creuser pour tout éventuel problème de configuration à venir :

Se soucier de la distribution LaTeX utilisée : dans texlive comme dans une version récente de MikTeX... on a asymptote ! Donc, il faut s'assurer dans le PATH de l'ordre des dossiers : j'ai rencontré des problèmes avec la version Asymptote de MikTeX sous W10 cet été et par manque de temps, j'ai cédé à la facilité de ré-installer la version autonome... mais en mettant cet ordre dans le PATH :
2017-12-03_100507_path.jpg
2017-12-03_100507_path.jpg (45.3 Kio) Vu 46 fois
Je ré-essaierai plus tard la version Asymptote de MikTeX.
Mais je me suis demandé cet été, sans avoir eu le temps de chercher, s'il y avait un bug dans la version de MikTeX et/ou s'il y avait des conflits entre les deux versions d'Asymptote.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 10/10/17) :
PC n°1 :Windows 10 - Asymptote(2.41)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 16.04LTS - Asymptote(2.42 git) + TexLive2017 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1337
Enregistré le : dim. 7 mars 2010, 14:50

Re: message d'erreur cygdrive [window7]

Message non lu par GM » dim. 3 déc. 2017, 10:53

Je n'avais pas les yeux ouverts quand j'ai lu le message d'erreur.

J'ai focalisé sur "error: could not load module"

... en omettant le "unexpected end of input".

C'est bien le point-virgule manquant qui génère l'erreur signalée !


Figure asymptote 97bb0c1cbe5ca87733a599fea1f8d046
*** Pour masquer/découvrir le code Asymptote qui a permis de créer la figure, il faut cliquer dessus. ;-) ***

CODE ASYMPTOTE de la figure ci-dessus : Tout sélectionner
  1. label("Hello world");
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 10/10/17) :
PC n°1 :Windows 10 - Asymptote(2.41)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 16.04LTS - Asymptote(2.42 git) + TexLive2017 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

malaka
Messages : 3
Enregistré le : ven. 14 juil. 2017, 11:37

Re: message d'erreur cygdrive [window7]

Message non lu par malaka » lun. 4 déc. 2017, 16:49

Merci ça fonctionne. C'est vraiment trop bête et indiqué dans le message d'erreur :roll:
Je vais vérifier tout mes fichiers qui me donnaient le même message d'erreur. Je restais toujours bloqué sur ce cygdrive et double slash que je pensais être la source du problème mais qui sait ...
Window 7 - TeXmaker 5.0.2 -Asymptote 2.41

Répondre