please install glut library, run ./configure, and recompile

Besoin d'aide pour installer Asymptote ?
maurice
Messages : 254
Enregistré le : jeu. 25 mars 2010, 13:00
Contact :

please install glut library, run ./configure, and recompile

Message non lu par maurice » jeu. 12 janv. 2012, 20:23

Bonsoir,

en testant le code d'un ami (récemment converti) je me suis rendu compte qu'il y a avait un problème avec OpenGL sur mon ordinateur :

Code : Tout sélectionner

$ asy -V -render=4 test.asy
/usr/local/share/asymptote/three.asy: 2976.13: runtime: to support onscreen rendering, please install glut library, run ./configure, and recompile
[maurice@localhost Fred]$


Je fais donc ce qu'on me dit et ./configure me renvoie les erreurs :

checking gsl/gsl_sf.h usability... no
checking gsl/gsl_sf.h presence... no
checking for gsl/gsl_sf.h... no
configure: *** Header file gsl_sf.h not found: will compile without optional special functions. ***
checking fftw3.h usability... no
checking fftw3.h presence... no
checking for fftw3.h... no
configure: *** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***
checking for glDepthMask in -lGL... no
checking for gluNewNurbsRenderer in -lGLU... no
configure: *** Could not find libGLU: will compile without OpenGL support ***
checking for glutMainLoop in -lglut... no
configure: *** Could not find libglut: will compile without GLUT support ***
checking for pid_t... yes


Poutant gsl, freeglut et libGLU sont installés :

Code : Tout sélectionner

$ yum list mesa-libGLU*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
mesa-libGLU.x86_64                       7.11.2-1.fc16                  @updates
Available Packages
mesa-libGLU.i686                         7.11.2-1.fc16                  updates
mesa-libGLU-devel.i686                   7.11.2-1.fc16                  updates
mesa-libGLU-devel.x86_64                 7.11.2-1.fc16                  updates

Code : Tout sélectionner

$ yum list freeglut
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
freeglut.x86_64                       2.6.0-6.fc15                       @fedora

Code : Tout sélectionner

$ yum list gsl
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
gsl.x86_64                          1.15-3.fc16                          @fedora


C'est la première fois que j'ai des problèmes pour compiler les sources....

Maurice
Doc 3D
Si ça ne marche pas, essayez la version pdf

Fedora 23 -- Asymptote 2.35 -- TeXlive 2013 -- emacs et/ou gedit

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1337
Enregistré le : dim. 7 mars 2010, 14:50

Re: please install glut library, run ./configure, and recompile

Message non lu par GM » jeu. 12 janv. 2012, 20:27

Une source de lecture relative au même type d'erreur (sur le forum officiel d'Asymptote) :

cf. message 14 de fabrice : JCBowman y donne des conseils.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 10/10/17) :
PC n°1 :Windows 10 - Asymptote(2.41)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 16.04LTS - Asymptote(2.42 git) + TexLive2017 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

maurice
Messages : 254
Enregistré le : jeu. 25 mars 2010, 13:00
Contact :

Re: please install glut library, run ./configure, and recompile

Message non lu par maurice » jeu. 12 janv. 2012, 20:50

Merci, une quinzaine de paquets supplémentaires installés, ça fonctionne bien.
J'ai du installer les paquet de développement (mesa-libGL-devel, gsl-devel, freeglut-devel).
Il me semble que c'est la 1ere fois que j'en ai besoin.
Changement de Asymptote ou de Fedora ?

Maurice
Doc 3D
Si ça ne marche pas, essayez la version pdf

Fedora 23 -- Asymptote 2.35 -- TeXlive 2013 -- emacs et/ou gedit

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1337
Enregistré le : dim. 7 mars 2010, 14:50

Re: please install glut library, run ./configure, and recompile

Message non lu par GM » jeu. 12 janv. 2012, 21:08

maurice a écrit :Merci, une quinzaine de paquets supplémentaires installés, ça fonctionne bien.

Ah ce que j'aime les problèmes vite réglés ! :-)
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 10/10/17) :
PC n°1 :Windows 10 - Asymptote(2.41)+MikTeX2.9 - Editeurs : Notepad++ et TeXworks.
Mes autres PC :Ubuntu 16.04LTS - Asymptote(2.42 git) + TexLive2017 - Editeur : TeXworks.
Merci de préciser la votre pour faciliter l'aide des autres !

Répondre