asy: error while loading shared libraries: libGLU.so.1

Pour toute demande d'aide sur des exemples non finalisés, c'est ici.
Les exemples aboutis et intéressants seront ajoutés aux sous-forums qui suivent.

Règles du forum
Pour toute demande d'aide pour la conception (ou la confirmation d'un code) d'une figure Asymptote, c'est ici.

J'invite ceux qui ont régulièrement des questions à poser à aller dans leur panneau de l'utilisateur pour indiquer dans la signature de leurs messages :

  1. Nom du système d'exploitation (W7 ou Ubuntu 12.04 ou ...)
  2. Version d'Asymptote et éditeur utilisé pour les figures Asymptote
  3. Distribution LaTeX et éditeur utilisé pour les tex.


On va gagner du temps dans les réponses !
Fabrice
Messages : 118
Enregistré le : sam. 13 mars 2010, 11:41

asy: error while loading shared libraries: libGLU.so.1

Message non lu par Fabrice » sam. 29 déc. 2018, 12:39

Bonjour,
Suite à une mise à jour de mon système qui a causé des soucis, j'ai refait une installation de Arch Linux en conservant mon ancien home, donc tous mes fichiers de configuration. Tous mes logiciels fonctionnent sauf Asymptote :

Code : Tout sélectionner

[viserion@archlinux ~]$ asy
asy: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
[viserion@archlinux ~]$ 
Merci.
Fabrice
Debian Strech + Asymptote 2.42-12 + Emacs24 + TeXLive 2017

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1419
Enregistré le : dim. 7 mars 2010, 14:50

Re: asy: error while loading shared libraries: libGLU.so.1

Message non lu par GM » sam. 29 déc. 2018, 23:42

Bonsoir,

je ne connais pas "Arch Linux" mais ce que je viens de voir sur la toile me suggérerait de vérifier ceci :

Code : Tout sélectionner

pacman -Q glu
et si un numéro de version est retourné, ceci :

Code : Tout sélectionner

pacman -Ql glu
pour vérifier l'installation de libglut.
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 31/03/19) :
PC n°1 :Windows 10 - Asymptote(2.59)+MikTeX2.9 - Editeurs : Notepad++, TeXworks, Visual Studio Code.
Mes autres PC : Ubuntu 18.04LTS - Asymptote(2.52-?? git) + TexLive2018
Mon serveur : Debian Jessie - Asymptote(2.52-1 git) + TexLive2018
Merci de préciser la votre !

Fabrice
Messages : 118
Enregistré le : sam. 13 mars 2010, 11:41

Re: asy: error while loading shared libraries: libGLU.so.1

Message non lu par Fabrice » dim. 30 déc. 2018, 11:23

Bonjour,
Je pense que tu as lu la question que j'ai posée sur le forum d'Arch Linux sous l'avatar viserion ; le problème est réglé !
Merci.
Fabrice
Debian Strech + Asymptote 2.42-12 + Emacs24 + TeXLive 2017

Avatar du membre
GM
Administrateur du site
Administrateur du site
Messages : 1419
Enregistré le : dim. 7 mars 2010, 14:50

Re: asy: error while loading shared libraries: libGLU.so.1

Message non lu par GM » dim. 30 déc. 2018, 12:22

Fabrice a écrit :
dim. 30 déc. 2018, 11:23
Je pense que tu as lu la question que j'ai posée sur le forum d'Arch Linux sous l'avatar viserion ;
Je n'avais pas fait attention à la date. Si j'avais réalisé que cela datait du même jour, j'aurais assurément deviné qu'il s'agissait de toi.
Fabrice a écrit :
dim. 30 déc. 2018, 11:23
le problème est réglé !
Il s'agissait donc d'installer glu ou pas ?
Index des fonctions - Exemple de lien donnant le résultat d'une recherche sur les mots 'arc' et 'triple' : http://asy.marris.fr/indexasy/?filtre=arc triple
Mes configurations (le 31/03/19) :
PC n°1 :Windows 10 - Asymptote(2.59)+MikTeX2.9 - Editeurs : Notepad++, TeXworks, Visual Studio Code.
Mes autres PC : Ubuntu 18.04LTS - Asymptote(2.52-?? git) + TexLive2018
Mon serveur : Debian Jessie - Asymptote(2.52-1 git) + TexLive2018
Merci de préciser la votre !

Fabrice
Messages : 118
Enregistré le : sam. 13 mars 2010, 11:41

Re: asy: error while loading shared libraries: libGLU.so.1

Message non lu par Fabrice » dim. 30 déc. 2018, 13:31

Salut,
GM a écrit :
dim. 30 déc. 2018, 12:22
Il s'agissait donc d'installer glu ou pas ?
Oui, il fallait installer ce paquet.
Fabrice
Debian Strech + Asymptote 2.42-12 + Emacs24 + TeXLive 2017

Répondre