1364 résultats trouvés

par GM
ven. 9 août 2019, 10:39
Forum : Accueil, News, SAV
Sujet : [New] Nouvelle version d'Asymptote
Réponses : 36
Vues : 64298

Re: [New] Nouvelle version d'Asymptote

Version 2.52 du 09/08/19 : https://sourceforge.net/projects/asymptote/files/2.52/ Release Notes for Version 2.52 Under MacOS X, 3D rendering is supported again, the xasy menubar is now visible, and the default PostScript previewer was changed to "open". VISUAL, EDITOR, and OS-specific editor overrid...
par GM
dim. 4 août 2019, 20:16
Forum : Accueil, News, SAV
Sujet : [New] Nouvelle version d'Asymptote
Réponses : 36
Vues : 64298

Re: [New] Nouvelle version d'Asymptote

Version 2.50 du 04/08/19 : https://sourceforge.net/projects/asymptote/files/2.50/ Version 2.51 du 06/08/19 : https://sourceforge.net/projects/asymptote/files/2.51/ Release Notes for Version 2.50 The Phong-Blinn lighting model was replaced by a physically based rendering model ; the ambient attribute...
par GM
jeu. 18 juil. 2019, 18:35
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

A propos du forum, je viens de vérifier : 1. par défaut, je passe par de l'eps. Dans ce cas, on a l'erreur avec opacity. 2. si on veut ajouter de la transparence, il faut passer via du pdf en ajoutant le settings.outformat='pdf'. Et cette deuxième façon fonctionne avec opacity (lorsque l'on a une ve...
par GM
jeu. 18 juil. 2019, 18:18
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

En fait, j'ai 4 figures, l'union et la différence donne cette erreur et l'intersection et le complémentaire compilent bien Je vois que j'ai oublié de te dire que j'ai su de suite quelle était la fonction en cause : opacity. Error: /undefined in .setopacityalpha Tout fonctionne dès que tu enlèves to...
par GM
jeu. 18 juil. 2019, 18:15
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

Je viens de lire qu'asymptote a longtemps utilisé gs avec l'option "-dSAFER" et c'est elle qui provoque l'erreur. Il faut donc passer au moins à la version 2.48 d'asymptote Mais le fait que l'on réussit à provoquer les deux cas sur le forum (erreur de compilation et compilation réussie) montre qu'un...
par GM
jeu. 18 juil. 2019, 18:00
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

Que donne l'utilisation de pdflatex ?

Code : Tout sélectionner

asy -f pdf -tex pdflatex M1201-1-union.asy
par GM
jeu. 18 juil. 2019, 17:57
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

Il faut que je revois comment j'ai codé la création d'image sur le forum car je m'étonne que l'ajout d'un settings.outformat='pdf' règle le problème.
par GM
jeu. 18 juil. 2019, 17:55
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

settings.outformat='pdf'; size(6cm); defaultpen(fontsize(11pt)); path p1=(-3,0)..(0,1)..(1,0)..(0,-1)..cycle; path p2=reflect((0,0), (0,1))*p1; filldraw(p1, lightblue+opacity(.7)); filldraw(p2, lightblue+opacity(.7)); draw(p1^^p2); // path p=(-3,0)..(0,1)..(1,0) draw((-3.5,0)..(0,1.5)..(3.5,0)..(0,...
par GM
jeu. 18 juil. 2019, 17:53
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

On voit dans le changelog d'Asymptote qu'il y a eu des modifications relativement à Ghostscript dans la 2.48 : http://asy.marris.fr/forum/viewtopic.php?f=4&p=3104#p3104. Mais le serveur du forum est avec Asymptote 2.50 et Ghostscript 9.26 et on a le problème aussi... ... donc la mise à jour d'Asymp...
par GM
jeu. 18 juil. 2019, 17:44
Forum : Les demandes d'aide
Sujet : code qui ne compile plus : erreur Ghostscript
Réponses : 12
Vues : 6336

Re: code qui ne compile plus : erreur Ghostscript

Bonjour, c'est un message d'erreur de ghostscript et cela compile effectivement chez moi avec une ancienne version 9.21 de ghostscript, alors que sur le serveur du forum la version doit être plus récente. On voit dans le changelog d'Asymptote qu'il y a eu des modifications relativement à Ghostscript...